myPOWERBLOCK

Network for PowerNation fans

Information

JEEPS

Group for Jeep enthusiast. Upload and share your photos with other Jeep owners. Ask questions, share tips, and watch video.

Members: 1345
Latest Activity: May 1, 2014

Discussion Forum

Tell us about your Jeep 82 Replies

Started by Puddle Pirate. Last reply by bryan Oct 20, 2013.

jeep TJ 3 Replies

Started by DON THOMAS. Last reply by JEEPING NH May 25, 2013.

Shimmy/Death Wobble 12 Replies

Started by Colby C Banks. Last reply by dustin mcglashan Jan 16, 2013.

WATCH 4X4 VIDEO

Loading… Loading feed

Comment Wall

Comment

You need to be a member of JEEPS to add comments!

Comment by Edward R Schrader on March 10, 2013 at 2:23pm
Rich hard to believe all that stuff went bad at the same time !!!
Comment by Austin Corbin III on March 9, 2013 at 10:43am

Mine has 149K of very interesting miles sill runs great hope that I don't have that problem on one of my interesting rides.

Comment by rich whisenant on February 22, 2013 at 7:56pm

when there is a foot of snow on the roads and your broke down. and that is your only transportation. your kind of screwed. I always do everything myself, but I had no other option.

Comment by James on February 22, 2013 at 7:26pm

I'm going to make an edjucated guess with just the information you posted and say it sounds like your ignition module went bad! I don't know if you have a warranty or not, but the dealer is THE LAST PLACE I would ever take any of my cars except my Nissan because it only has 12,000 miles on it! Keep us updated but PLEASE don't let the dealer work on it, PLEASE! You will lose your ASS!

Comment by Edward R Schrader on February 22, 2013 at 6:20pm
That means I got 50,000 to go before I have to worry ....
Comment by rich whisenant on February 22, 2013 at 6:13pm

149,000

Comment by Edward R Schrader on February 22, 2013 at 6:00pm
Dam how many miles u got on the Jeep ??
Comment by rich whisenant on February 22, 2013 at 5:56pm

battery, sensor throttle body,ignition coil,rotor, distr. cap,plug wires .and lots of money.

Comment by Edward R Schrader on February 22, 2013 at 5:22pm
Oxygen sensor maybe. ??
Comment by rich whisenant on February 22, 2013 at 4:59pm

nope, broke down today going to work. It just shut off , and would not start. Had to get towed to dealer. Was not cheap. But when your broke down ,you got to do what ever you got to do.

   

 

Members (1345)

 
 
 

© 2017   Created by Gearhead.   Powered by

Badges  |  Report an Issue  |  Terms of Service